In previous lessons I explained the OSPF non-broadcast and broadcast network types. Now we are going to look at the OSPF point-to-multipoint network type. This is the topology that we will use:
There are a couple of things that you need to be aware of:
- Automatic neighbor discovery so no need to configure OSPF neighbors yourself.
- No DR/BDR election since OSPF sees the network as a collection of point-to-point links.
- Only a single IP subnet is used in the topology above.
- Make sure your frame-relay network is configured with the broadcast keyword.
Let’s take a look at the configuration:
Hub(config)#interface serial 0/0
Hub(config-if)#ip address 192.168.123.1 255.255.255.0
Hub(config-if)#encapsulation frame-relay
Hub(config-if)#ip ospf network point-to-multipoint
Hub(config-if)#exit
Hub(config)#router ospf 1
Hub(config-router)#network 192.168.123.0 0.0.0.255 area 0
This is the hub configuration. I changed the network type to point-to-multipoint and advertised the 192.168.123.0 /24 network in OSPF. Let’s look at the spoke router configuration:
Spoke1(config)#interface serial 0/0
Spoke1(config-if)#ip address 192.168.123.2 255.255.255.0
Spoke1(config-if)#encapsulation frame-relay
Spoke1(config-if)#ip ospf network point-to-multipoint
Spoke1(config-if)#exit
Spoke1(config)#router ospf 1
Spoke1(config-router)#network 192.168.123.0 0.0.0.255 area 0
Spoke2(config)#interface serial 0/0
Spoke2(config-if)#ip address 192.168.123.3 255.255.255.0
Spoke2(config-if)#encapsulation frame-relay
Spoke2(config-if)#ip ospf network point-to-multipoint
Spoke2(config-if)#exit
Spoke2(config)#router ospf 1
Spoke2(config-router)#network 192.168.123.0 0.0.0.255 area 0
Just a basic configuration. You’ll have to change the OSPF network type and type in the correct network statements in order to become OSPF neighbors.
Don’t forget that you’ll require the broadcast keyword for your frame-relay maps or this will not work. By default Inverse ARP will do this but if you disabled Inverse ARP you’ll have to create the correct frame-relay maps yourself.
Let’s check if we have OSPF neighbors:
Hub#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.168.123.3 0 FULL/ - 00:01:35 192.168.123.3 Serial0/0
192.168.123.2 0 FULL/ - 00:01:56 192.168.123.2 Serial0/0
You can see that the hub router has two OSPF neighbors and that there is no DR/BDR election.
hostname Hub
!
interface Serial0/0
ip address 192.168.123.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
clock rate 2000000
!
router ospf 1
network 192.168.123.0 0.0.0.255 area 0
!
end
hostname Spoke1
!
interface Serial0/0
ip address 192.168.123.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
clock rate 2000000
!
router ospf 1
network 192.168.123.0 0.0.0.255 area 0
!
end
hostname Spoke2
!
interface Serial0/0
ip address 192.168.123.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
clock rate 2000000
!
router ospf 1
network 192.168.123.0 0.0.0.255 area 0
!
end
That’s it for now, I hope you enjoyed this example! Feel free to ask any questions.
No comments:
Post a Comment