Thursday, February 20, 2020

OSPF Broadcast Network Type over Frame-Relay

In a previous lesson I explained the OSPF Non-Broadcast Network Type. Now it’s time for the broadcast network type. If you understand non-broadcast then this one is easy. It’s the EXACT same thing except we don’t have to configure neighbors. OSPF will use multicast and discover OSPF neighbors automatically. The broadcast network type is the default for Ethernet interfaces.
This is the topology that we’ll use:
ospf network type topology
Hub(config)#interface serial 0/0
Hub(config-if)#ip address 192.168.123.1 255.255.255.0
Hub(config-if)#encapsulation frame-relay
Hub(config-if)#ip ospf network broadcast
Hub(config-if)#exit
Hub(config)#router ospf 1
Hub(config-router)#network 192.168.123.0 0.0.0.255 area 0
Here is the configuration of the Hub router. You can see I used the ip ospf network broadcast command to change the OSPF network type. Here are the spoke routers:
Spoke1(config)#interface serial 0/0
Spoke1(config-if)#ip address 192.168.123.2 255.255.255.0
Spoke1(config-if)#encapsulation frame-relay 
Spoke1(config-if)#ip ospf network broadcast 
Spoke1(config-if)#ip ospf priority 0
Spoke1(config-if)#exit
Spoke1(config)#router ospf 1
Spoke1(config-router)#network 192.168.123.0 0.0.0.255 area 0
Spoke2(config)#interface serial 0/0
Spoke2(config-if)#ip address 192.168.123.3 255.255.255.0
Spoke2(config-if)#encapsulation frame-relay 
Spoke2(config-if)#ip ospf network broadcast 
Spoke2(config-if)#ip ospf priority 0
Spoke2(config-if)#exit
Spoke2(config)#router ospf 1
Spoke2(config-router)#network 192.168.123.0 0.0.0.255 area 0
Make sure you set the priority to 0 for the spoke routers. We don’t want them to become the DR or BDR!
Make sure you have a frame-relay map statement with the broadcast keyword or you won’t be able to send multicast on your frame-relay network. By default Inverse ARP is enabled and will do this for you…if you don’t have inverse ARP, make sure you add it!
Hub#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.123.2     0   FULL/DROTHER    00:00:30    192.168.123.2   Serial0/0
192.168.123.3     0   FULL/DROTHER    00:00:35    192.168.123.3   Serial0/0
Here you can see that the hub router is the DR because the spoke routers are DROTHERS.
hostname Hub
!
interface Serial0/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 clock rate 2000000
!
router ospf 1
 network 192.168.123.0 0.0.0.255 area 0
!
end
hostname Spoke1
!
interface Serial0/0
 ip address 192.168.123.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 clock rate 2000000
!
router ospf 1
 network 192.168.123.0 0.0.0.255 area 0
!
end
hostname Spoke2
!
interface Serial0/0
 ip address 192.168.123.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 clock rate 2000000
!
router ospf 1
 network 192.168.123.0 0.0.0.255 area 0
!
end

That’s all I wanted to show you, if you have any more questions please let me know!

No comments:

Post a Comment