Thursday, February 20, 2020

OSPF Point-to-Multipoint Non-Broadcast Network Type over Frame-Relay



In a previous lesson I showed you how to configure the OSPF point-to-multipoint network type. This time we’ll look at the OSPF point-to-multipoint non-broadcast network type. It’s the exact same thing but we’ll have to specify OSPF neighbors ourselves. Here is the topology that we’ll use:
OSPF Network Type Topology
There are a couple of things that you need to be aware of:
  • No Automatic neighbor discovery so you need to configure OSPF neighbors yourself!
  • No DR/BDR election since OSPF sees the network as a collection of point-to-point links.
  • Only a single IP subnet is used in the topology above.
Here’s the configuration for the Hub router:
Hub(config)#interface serial 0/0
Hub(config-if)#ip address 192.168.123.1 255.255.255.0
Hub(config-if)#encapsulation frame-relay
Hub(config-if)#ip ospf network point-to-multipoint non-broadcast
Hub(config-if)#exit
Hub(config)#router ospf 1
Hub(config-router)#network 192.168.123.0 0.0.0.255 area 0
Hub(config-router)#neighbor 192.168.123.2 Hub(config-router)#neighbor 192.168.123.3
This is the hub configuration. I changed the network type to point-to-multipoint non-broadcast, advertised the 192.168.123.0 /24 network in OSPF and most important…specified the OSPF neighbors myself. Let’s look at the spoke router configuration:
Spoke1(config)#interface serial 0/0
Spoke1(config-if)#ip address 192.168.123.2 255.255.255.0
Spoke1(config-if)#encapsulation frame-relay 
Spoke1(config-if)#ip ospf network point-to-multipoint non-broadcast
Spoke1(config-if)#exit
Spoke1(config)#router ospf 1
Spoke1(config-router)#network 192.168.123.0 0.0.0.255 area 0
Spoke2(config)#interface serial 0/0
Spoke2(config-if)#ip address 192.168.123.3 255.255.255.0
Spoke2(config-if)#encapsulation frame-relay 
Spoke2(config-if)#ip ospf network point-to-multipoint non-broadcast
Spoke2(config-if)#exit
Spoke2(config)#router ospf 1
Spoke2(config-router)#network 192.168.123.0 0.0.0.255 area 0
Just a basic configuration. You’ll have to change the OSPF network type and type in the correct network statements in order to become OSPF neighbors. Let’s verify the configuration:
Hub#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.123.3     0   FULL/  -        00:01:35    192.168.123.3   Serial0/0
192.168.123.2     0   FULL/  -        00:01:56    192.168.123.2   Serial0/0
As you can see above the Hub router has two neighbors. There is no DR/BDR election. That’s all there is to it!
hostname Hub
!
interface Serial0/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint non-broadcast
 clock rate 2000000
!
router ospf 1
 network 192.168.123.0 0.0.0.255 area 0
 neighbor 192.168.123.3
 neighbor 192.168.123.2
!
end
hostname Spoke1
!
interface Serial0/0
 ip address 192.168.123.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint non-broadcast
 clock rate 2000000
!
router ospf 1
 network 192.168.123.0 0.0.0.255 area 0
!
end
ostname Spoke2
!
interface Serial0/0
 ip address 192.168.123.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint non-broadcast
 clock rate 2000000
!
router ospf 1
 network 192.168.123.0 0.0.0.255 area 0
!
end
If you have any questions just leave a comment.

No comments:

Post a Comment