Thursday, February 20, 2020

OSPF Point-to-Point Network Type over Frame-Relay

In a number of lessons I covered the OSPF network types. This lesson is the final one and will cover the OSPF Point-to-Point Network Type. I will be using a frame-relay point-to-point topology to demonstrate it, here it is:
ospf p2p topology
Here’s what you need to know about OSPF point-to-point:
  • Automatic neighbor discovery so no need to configure OSPF neighbors yourself.
  • No DR/BDR election since OSPF sees the network as a collection of point-to-point links.
  • Normally uses for point-to-point sub-interfaces with an IP subnet per link.
  • Can also be used with multiple PVCs using only one subnet.
Let me show you the configuration of the Hub router:
Hub(config)#interface serial 0/0
Hub(config-if)#encapsulation frame-relay 
Hub(config-if)#exit
Hub(config)#interface serial 0/0.102 point-to-point 
Hub(config-subif)#ip address 192.168.12.1 255.255.255.0
Hub(config-subif)#frame-relay interface-dlci 102
Hub(config-subif)#exit
Hub(config)#interface serial 0/0.103 point-to-point
Hub(config-subif)#ip address 192.168.13.1 255.255.255.0
Hub(config-subif)#frame-relay interface-dlci 103
I am using two sub-interfaces and assigning the correct DLCI number to each sub-interface. Now let’s configure the spoke routers:
Spoke1(config)#interface serial 0/0
Spoke1(config-if)#encapsulation frame-relay 
Spoke1(config-if)#interface serial 0/0.201 point-to-point
Spoke1(config-subif)#ip address 192.168.12.2 255.255.255.0
Spoke1(config-if)#frame-relay interface-dlci 201
Spoke2(config)#interface serial 0/0
Spoke2(config-if)#encapsulation frame-relay 
Spoke2(config-if)#interface serial 0/0.301 point-to-point
Spoke2(config-subif)#ip address 192.168.13.3 255.255.255.0
Spoke2(config-if)#frame-relay interface-dlci 301
Above you see a sub-interface for each spoke router with the correct DLCI number.
Keep in mind that the physical interface for frame-relay is always point-to-multipoint. If the technical requirements state that you need to use a point-to-point interface then you should create a sub-interface.
Let’s enable OSPF for all routers:
Hub(config)#router ospf 1
Hub(config-router)#network 192.168.12.0 0.0.0.255 area 0
Hub(config-router)#network 192.168.13.0 0.0.0.255 area 0
Spoke1(config)#router ospf 1
Spoke1(config-router)#network 192.168.12.0 0.0.0.255 area 0
Spoke2(config)#router ospf 1
Spoke2(config-router)#network 192.168.13.0 0.0.0.255 area 0
Configure OSPF for all subnets, nothing special here…let’s see if we have any OSPF neighbors:
Hub#show ip ospf neighbor 

Neighbor ID     Pri   State        Dead Time   Address         Interface
192.168.123.3     0   FULL/  -     00:00:34    192.168.13.3    Serial0/0.103
192.168.123.2     0   FULL/  -     00:00:36    192.168.12.2    Serial0/0.102
As you can see we have OSPF neighbors…mission accomplished!
hostname Hub
!
ip cef
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.102 point-to-point
 ip address 192.168.12.1 255.255.255.0
 frame-relay interface-dlci 102
!
interface Serial0/0.103 point-to-point
 ip address 192.168.13.1 255.255.255.0
 frame-relay interface-dlci 103
!
router ospf 1
 network 192.168.12.0 0.0.0.255 area 0
 network 192.168.13.0 0.0.0.255 area 0
!
end
hostname Spoke1
!
ip cef
!
interface Serial0/0.201 point-to-point
 ip address 192.168.12.2 255.255.255.0
 frame-relay interface-dlci 201
!
router ospf 1
 network 192.168.12.0 0.0.0.255 area 0
!
end
hostname Spoke2
!
ip cef
!
interface Serial0/0.301 point-to-point
 ip address 192.168.13.3 255.255.255.0
 frame-relay interface-dlci 301
!
router ospf 1
 network 192.168.13.0 0.0.0.255 area 0
!
end
If you have any questions feel free to ask them.

No comments:

Post a Comment