The multicast that you are probably familiar with (PIM sparse and dense mode) using IGMPv2 are also known as ASM (Any Source Multicast). This means that the receivers really don’t care what source they receive multicast traffic from, all sources are accepted.
Using sparse mode our receivers require the RP (Rendezvous Point) to discover new sources in the network. SSM (Source Specific Multicast) requires IGMPv3 and lets us join multicast groups from specified source addresses.
Besides just joining any group, the receiver is able to receive the group from a specified source. When we use SSM / IGMPv3 there are no shared trees. We only build SPTs (Shortest Path Trees) towards our sources. This also means that we don’t use any RPs …you won’t need Auto-RP or Bootstrap anymore!
Configuring source specific multicast is pretty easy, let’s use the following topology to take a look at the configuration:
We have a very small network with only 3 routers. Let’s prepare them by enabling OSPF and multicast routing:
R1,R2 and R3:
ip multicast-routing
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
Let’s enable PIM sparse-mode on the interfaces:
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip pim sparse-mode
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip pim sparse-mode
R2(config-if)#interface fastEthernet 0/1
R2(config-if)#ip pim sparse-mode
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip pim sparse-mode
Now we can dive int the configuration of SSM. First we’ll enable SSM on all routers. If you do not specify a group then the 232.0.0.0/8 range will be used. If you do try a (*,G) join for any group in the SSM range then it will be dropped.
R1,R2 and R3:
ip pim ssm default
Next step is to enable IGMPv3 on the source and receiver:
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip igmp version 3
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip igmp version 3
Now we’ll configure R3 to join a multicast group address in the 232.0.0.0/8 range and we’ll specify R1 as the source:
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip igmp join-group 232.1.1.1 source 192.168.12.1
Let’s take a look at the multicast routing table of R2:
R2#show ip mroute 232.1.1.1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.168.12.1, 232.1.1.1), 00:00:18/00:03:10, flags: sT
Incoming interface: FastEthernet0/0, RPF nbr 192.168.12.1
Outgoing interface list:
FastEthernet0/1, Forward/Sparse, 00:00:18/00:03:10
Above you see the multicast routing table of R2. See how it build the SPT towards R1? Another interesting output to look at is the IGMP groups overview:
R3#show ip igmp groups 232.1.1.1 detail
Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit
Interface: FastEthernet0/0
Group: 232.1.1.1
Flags: L SSM
Uptime: 00:04:30
Group mode: INCLUDE
Last reporter: 192.168.23.3
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
192.168.12.1 00:04:30 00:02:34 stopped Yes RL
Above you can see the source address and the “SSM” flag that has been set. That’s all there is to it…without RPs, Auto-RP and Bootstrap it’s quite easy to configure!
hostname R1
!
ip cef
!
ip multicast-routing
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
ip pim sparse-mode
ip igmp version 3
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
ip pim ssm default
!
end
hostname R2
!
ip cef
!
ip multicast-routing
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
ip pim sparse-mode
!
interface FastEthernet0/1
ip address 192.168.23.2 255.255.255.0
ip pim sparse-mode
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
ip pim ssm default
!
end
hostname R3
!
ip cef
!
ip multicast-routing
!
interface FastEthernet0/0
ip address 192.168.23.3 255.255.255.0
ip pim sparse-mode
ip igmp version 3
ip igmp join-group 232.1.1.1 source 192.168.12.1
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
ip pim ssm default
!
end
If you have any questions just leave a comment.
No comments:
Post a Comment