Friday, February 21, 2020

IPv6 EIGRP on Cisco IOS Router

Cisco’s EIGRP is one of the routing protocols that is suitable for IPv6. Configuration is a bit different and in this lesson I’ll demonstrate to you how to configure it. This is the topology we’ll use:
R1 R2 IPv6 addresses on loopback interfaces
Note that I don’t have any global unicast IPv6 addresses on the FastEthernet interface because the EIGRP updates will be sent using the link-local addresses.

Configuration

First we will enable routing for IPv6:
R1 & R2
(config)#ipv6 unicast-routing
And let’s configure some IPv6 addresses:
R1 & R2
(config)#interface GigabitEthernet 0/1
(config-if)#ipv6 enable 
R1(config)#interface loopback 0
R1(config-if)#ipv6 address 2001::1/128
R2(config)#interface loopback 0
R2(config-if)#ipv6 address 2001::2/128
Enabling IPv6 on the Gigabit interfaces will generate an IPv6 link local address. The loopback interfaces will have a global unicast address. Let’s verify our work:
R1#show ipv6 interface brief
GigabitEthernet0/1     [up/up]
    FE80::F816:3EFF:FE7B:61CA
Loopback0              [up/up]
    FE80::F816:3EFF:FEC5:1BD7
    2001::1
R2#show ipv6 interface brief 
GigabitEthernet0/1     [up/up]
    FE80::F816:3EFF:FE8F:4F66
Loopback0              [up/up]
    FE80::F816:3EFF:FED1:4100
    2001::2
After configuring the IPv6 addresses on the loopback interface you can see the global unicast and the link-local IPv6 addresses.
This is how you enable EIGRP for IPv6:
R1(config)#ipv6 router eigrp 1
R1(config-rtr)#router-id 1.1.1.1
R1(config-rtr)#no shutdown

R1(config)#interface GigabitEthernet 0/1
R1(config-if)#ipv6 eigrp 1

R1(config)#interface loopback 0
R1(config-if)#ipv6 eigrp 1
R2(config)#ipv6 router eigrp 1
R2(config-rtr)#router-id 2.2.2.2
R2(config-rtr)#no shutdown

R2(config)#interface GigabitEthernet 0/1
R2(config-if)#ipv6 eigrp 1

R2(config)#interface loopback 0
R2(config-if)#ipv6 eigrp 1
First, you need to start EIGRP with the ipv6 router eigrp command. The number you see is the autonomous system number and it has to match on both routers. Each EIGRP router needs a router ID which is the highest IPv4 address on the router.
If you don’t have any IPv4 addresses you need to specify it yourself with the router-id command. By default, the EIGRP process is in shutdown mode and you need to type no shutdown to activate it.
Last step is to enable it on the interfaces with the ipv6 eigrp command. Let’s verify our configuration:
R1#show ipv6 eigrp neighbors 
EIGRP-IPv6 Neighbors for AS(1)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   Link-local address:     Gi0/1                    13 00:01:31 1586  5000  0  3
    FE80::F816:3EFF:FE8F:4F66
R2#show ipv6 eigrp neighbors 
EIGRP-IPv6 Neighbors for AS(1)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   Link-local address:     Gi0/1                    10 00:01:44    9   100  0  3
    FE80::F816:3EFF:FE7B:61CA
Use show ipv6 eigrp neighbors to verify you have an adjacency.
R1#show ipv6 route eigrp 
IPv6 Routing Table - default - 3 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001::2/128 [90/130816]
     via FE80::F816:3EFF:FE8F:4F66, GigabitEthernet0/1
R2#show ipv6 route eigrp 
IPv6 Routing Table - default - 3 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       RL - RPL, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       la - LISP alt, lr - LISP site-registrations, ld - LISP dyn-eid
       a - Application
D   2001::1/128 [90/130816]
     via FE80::F816:3EFF:FE7B:61CA, GigabitEthernet0/1
Here we go…we have an EIGRP prefix in the routing table. That’s all there is to it!
hostname R1
!
ipv6 unicast-routing 
!
interface loopback 0
 ipv6 address 2001::1/128
 ipv6 eigrp 1
!
interface GigabitEthernet 0/1
 ipv6 enable
 ipv6 eigrp 1
!
ipv6 router eigrp 1
 router-id 1.1.1.1
 no shutdown
!
end
hostname R2
!
ipv6 unicast-routing 
!
interface loopback 0
 ipv6 address 2001::2/128
 ipv6 eigrp 1
!
interface GigabitEthernet 0/1
 ipv6 enable
 ipv6 eigrp 1
!
ipv6 router eigrp 1
 router-id 2.2.2.2
 no shutdown
!
end

No comments:

Post a Comment