Thursday, February 20, 2020

How to configure Redistribution between EIGRP and RIP

In previous lessons I explained the basics of redistribution and I also showed you how to configure redistribution between OSPF and RIP. This time we’ll take a look at redistribution between EIGRP and RIP. Let’s take a look at the topology that we will use:
EIGRP RIP Redistribution R1 R2 R3
Above we have 3 routers. Router R1 and R2 are configured for EIGRP. R2 and R3 are both configured for RIP.

First we will configure EIGRP and RIP without any redistribution:
R1(config)#router eigrp 12
R1(config-router)#no auto-summary 
R1(config-router)#network 1.1.1.0 0.0.0.255
R1(config-router)#network 192.168.12.0
R2(config)#router eigrp 12
R2(config-router)#no auto-summary 
R2(config-router)#network 192.168.12.0
R2(config)#router rip
R2(config-router)#no auto-summary 
R2(config-router)#version 2
R2(config-router)#network 192.168.23.0
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.23.0
R3(config-router)#network 3.3.3.0
Above are the router configurations I’ve used, nothing special…redistribution doesn’t happen automatically this is something we have to do ourselves. Let’s configure it:
R2(config)#router eigrp 12
R2(config-router)#redistribute rip metric 1500 100 255 1 1500
I’m redistributing RIP into EIGRP and I have to specify the metrics. Pick whatever values you like. In you don’t specify the seed metric than the default one will be infinity and your redistributed routes don’t show up!
R2(config)#router eigrp 12
R2(config-router)#default-metric 1500 100 255 1 1500
You can also configure the seed metric globally for EIGRP using the default-metric command.
R1#show ip route eigrp 
     3.0.0.0/24 is subnetted, 1 subnets
D EX    3.3.3.0 [170/1734656] via 192.168.12.2, 00:01:39, FastEthernet0/0
D EX 192.168.23.0/24 [170/1734656] via 192.168.12.2, 00:03:49, FastEthernet0/0
This is what router R1’s routing table now looks like. You can see these networks show up as EIGRP external and the administrative distance is 170.
R2(config)#router rip
R2(config-router)#redistribute eigrp 12 metric 10
To redistribute EIGRP into RIP we’ll have to specify the AS number for EIGRP (12) and the metric (hop count).
R3#show ip route rip
R    192.168.12.0/24 [120/10] via 192.168.23.2, 00:00:06, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
R       1.1.1.0 [120/10] via 192.168.23.2, 00:00:06, FastEthernet0/0
And here you see the RIP routes, that’s all there is to it.
hostname R1
!
interface Loopback 0
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
!
router eigrp 12
 no auto-summary
 network 1.1.1.0 0.0.0.255
 network 192.168.12.0
!
end
hostname R2
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.23.2 255.255.255.0
!
router eigrp 12
 no auto-summary
 network 192.168.12.0
 redistribute rip metric 1500 100 255 1 1500
 default-metric 1500 100 255 1 1500
!
router rip
 no auto-summary
 version 2
 network 192.168.23.0
 redistribute eigrp 12 metric 10
!
end
hostname R3
!
interface Loopback 0
 ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.23.3 255.255.255.0
!
router rip
 no auto-summary
 version 2
 network 192.168.23.0
 network 3.3.3.0
!
end
I hope this is useful to you! If you have any questions feel free to ask.


No comments:

Post a Comment