Thursday, February 20, 2020

How to configure EIGRP Summarization

In this lesson we’ll take a look at EIGRP summarization. The cool thing about EIGRP and summarization is that it’s easy to do and can be done on the interface-level. Here’s the topology that we’ll use:
eigrp summarization lab topology
Let’s create a basic EIGRP configuration:
R1(config)#router eigrp 1
R1(config-router)#no auto-summary 
R1(config-router)#network 192.168.12.0
R1(config-router)#network 172.16.0.0
R2(config)#router eigrp 1
R2(config-router)#no auto-summary 
R2(config-router)#network 192.168.12.0
Just a basic EIGRP configuration. This is what the routing table of R2 looks like:
R2#show ip route eigrp 
     172.16.0.0/24 is subnetted, 2 subnets
D       172.16.0.0 [90/30720] via 192.168.12.1, 00:02:28, FastEthernet0/0
D       172.16.1.0 [90/30720] via 192.168.12.1, 00:02:28, FastEthernet0/0
Two entries as expected. Now let’s create that summary:
R1(config)#interface fastEthernet 2/0
R1(config-if)#ip summary-address eigrp 1 172.16.0.0 255.255.254.0
Use the ip summary-address eigrp command to specify the summary. Now the routing table will look like this:
R2#show ip route eigrp 
     172.16.0.0/23 is subnetted, 1 subnets
D       172.16.0.0 [90/30720] via 192.168.12.1, 00:00:53, FastEthernet0/0
The two networks disappear and a single entry will appear on R2. The metric is 30720, how did it get this value? When you advertise a summary, the router advertising the summary will use the lowest metric of all networks that fall within the range of the summary. That’s the one it will use for the summary. It is possible to manually set the metric for each summary. Here’s how:
R1(config)#router eigrp 1
R1(config-router)#summary-metric ?
The summary-metric requires you to set the bandwidth, delay, reliability, load, and MTU. Let’s try something:
R1(config-router)#summary-metric 172.16.0.0 255.255.254.0 100000 10 255 0 1500
R2 will now see the new metric:
R2#show ip route eigrp 
     172.16.0.0/24 is subnetted, 2 subnets
D       172.16.0.0 [90/2562816] via 192.168.12.1, 00:02:28, FastEthernet0/0
D       172.16.1.0 [90/2562816] via 192.168.12.1, 00:02:28, FastEthernet0/0
Advertising a summary also changes something in the routing table of R1:
R1#show ip route eigrp 
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.0.0/23 is a summary, 00:01:38, Null0
EIGRP will create an entry in the routing table for the summary and it’s pointing to the null0 interface. It does this to protect itself against routing loops. When you use summaries it’s possible that other routers will send traffic to you for networks that you have no clue about where they are. When this happens the traffic will be forwarded to the null0 interface and dropped.
hostname R2
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
!
router eigrp 1
 network 192.168.12.0
!
end
hostname R1
!
interface FastEthernet2/0
 ip address 192.168.12.1 255.255.255.0
 ip summary-address eigrp 1 172.16.0.0 255.255.254.0
!
interface FastEthernet0/0
 ip address 172.16.0.1 255.255.255.0
!
interface FastEthernet1/0
 ip address 172.16.1.1 255.255.255.0
!
router eigrp 1
 network 172.16.0.0
 network 192.168.12.0
!
end

No comments:

Post a Comment